Mass Problem area INDOVISION Jakarta

August 13, Sat
Affected Service: Global Internet Access Local Internet Access
  • Identified
    Telah terjadi gangguan masal yang berdampak ke 364 pelanggan Area: INDOVISION

    11:37, Aug 12 WIB
  • Resolved
    Tim selesai penyambungan

    18:41, Aug 13 WIB
Back to current status