Mass Problem Area CEMPAKA PUTIH

August 22, Mon
Affected Service: Global Internet Access Local Internet Access
  • Identified
    Sedang dalam koordinasi dengan team terkait

    11:27, Aug 22 WIB
  • Resolved
    Team selesai proses penyambungan kabel

    14:44, Aug 22 WIB
Back to current status