Mass Problem area OLT KARAH SURABAYA

August 16, Tue
Affected Service: Global Internet Access Local Internet Access
  • Identified
    06.45 Tim prepare

    07:31, Aug 16 WIB
  • Resolved
    Tim selesai penyambungan

    13:44, Aug 16 WIB
Back to current status