Mass Problem area GOMBEL 1 SEMARANG

July 30, Sat
Affected Service: Global Internet Access Local Internet Access
  • Identified
    Sedang dalam koordinasi dengan team terkait

    08:19, Jul 30 WIB
  • Resolved

    08.37 kegiatan selesai

    08:56, Jul 30 WIB
Back to current status