Mass Problem Wilayah PANCORANMAS

August 22, Mon
Affected Service: Local Internet Access
  • Identified
    Sedang dalam koordinasi dengan team terkait

    00:35, Aug 22 WIB
  • Resolved
    Team selesai proses penyambungan kabel

    03:12, Aug 22 WIB
Back to current status